I am facing strange problem.

I am facing a strange problem.
I receive Qmobile A300 with filesystem error problem.
First of all i take backup with cm2 logs are here.

Code:

Start  at : [2/15/2016 / 7:51:53 PM]
Operation : Check / Read Info [ v1.40 ]

1. Power Off Phone , Remove battery , Insert back
2. Insert USB cable. In some cases require hold BootKey

Wait for phone...
Phone found! [ 8 ]
Sync...
Inital regs read done
Boot Info :
BB_CPU_ID : 6572
BB_CPU_HW : CA01
BB_CPU_SW : 8C00
BB_CPU_SB : 0000
BB_CPU_NM : [MediaTek] MT6572_S00
Processing BROM stage
BLVersion : 0x01
SecCfgVal : 0x00000000
BromVersion : 0xFF
BLVersion : 0x01
Preloader Status : Alive
Processing DA stage
DA Select done , sending
DA Ver : MTK_AllInOne_DA_v5.1540.01.01
NAND_ID : 00000000000000000000000000000000
eMMC_ID : 90014A4834473164048602A340DC4101
DA Stat : v4.2 on BBID : 0x88
DA Sent. Configure setting now ...
DA started successuflly
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0090 , OEM : 014A
[eMMC] : FLASH_INF : [HYNIX] , d1G4
[eMMC] : FLASH_CID : 90014A4834473164048602A340DC4101
[eMMC] : FLASH_EXT : 0x00200000 , 0x00200000 , 0x00200000
[eMMC] : FLASH_LEN : 0x00000000E7000000
[eMMC] : FLASH_UCP : 3696 MiB
INT RAM    : 0x00020000
EXT RAM    : 0x20000000
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

[AP] : Initial info read Ok!

Brand    : QMobile
ProdName  : A300
ProdModel : QMobile A300
Device    : QMobile A300
AndroidVer: 4.2.2
MTKxCPU  : MT6572
MTKxPRJ  : ALPS.JB3.MP.V1.P65

EXTRA :
LCD [0] : ili9806c_fwvga_dsi_vdo_txdkj
LCD [1] : otm8018b_dsi_vdo
LCD Res : 854x480
TOUCH [0] : GT9XX
TOUCH [1] : FT5x36
CAM [0] : ov5645_mipi_yuv
CAM [1] : ov5644_mipi_yuv
CAM [2] : hi704_yuv
CAM [3] : sp0a19_yuv
MODEM : tinno72_s7810bp_pk_gprs_gemini
LOCALE : en_US es_ES zh_CN zh_TW ru_RU pt_BR fr_FR de_DE tr_TR it_IT in_ID ms_MY vi_VN ar_EG ur_PK fa_IR th_TH pt_PT nl_NL el_GR hu_HU tl_PH ro_RO cs_CZ iw_IL my_MM km_KH ko_KR hdpi

Done!
Elapsed: 00:00:18
Reconnect Power/Cable!

Finish at : [2/15/2016 / 7:52:11 PM]

Start  at : [2/15/2016 / 7:52:22 PM]
Operation : Read Flash [ v1.40 ]

1. Power Off Phone , Remove battery , Insert back
2. Insert USB cable. In some cases require hold BootKey

Wait for phone...
Phone found! [ 8 ]
Sync...
Inital regs read done
Boot Info :
BB_CPU_ID : 6572
BB_CPU_HW : CA01
BB_CPU_SW : 8C00
BB_CPU_SB : 0000
BB_CPU_NM : [MediaTek] MT6572_S00
Processing BROM stage
BLVersion : 0x01
SecCfgVal : 0x00000000
BromVersion : 0xFF
BLVersion : 0x01
Preloader Status : Alive
Processing DA stage
DA Select done , sending
DA Ver : MTK_AllInOne_DA_v5.1540.01.01
NAND_ID : 00000000000000000000000000000000
eMMC_ID : 90014A4834473164048602A340DC4101
DA Stat : v4.2 on BBID : 0x88
DA Sent. Configure setting now ...
DA started successuflly
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0090 , OEM : 014A
[eMMC] : FLASH_INF : [HYNIX] , d1G4
[eMMC] : FLASH_CID : 90014A4834473164048602A340DC4101
[eMMC] : FLASH_EXT : 0x00200000 , 0x00200000 , 0x00200000
[eMMC] : FLASH_LEN : 0x00000000E7000000
[eMMC] : FLASH_UCP : 3696 MiB
INT RAM    : 0x00020000
EXT RAM    : 0x20000000
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

Reading Flash Conent now ...

Brand    : QMobile
ProdName  : A300
ProdModel : QMobile A300
Device    : QMobile A300
AndroidVer: 4.2.2
MTKxCPU  : MT6572
MTKxPRJ  : ALPS.JB3.MP.V1.P65

[Read Ok] : preloader_s7810bp.bin
[Read Ok] : MBR
[Read Ok] : EBR1
[Read Ok] : lk.bin
[Read Ok] : boot.img
[Read Ok] : recovery.img
[Read Ok] : secro.img
[Read Ok] : logo.bin
[Read Ok] : system.img
[Read Ok] : cache.img
[Read Ok] : userdata.img
[Read Ok] : fat.img

[ScatCFG] : MT6572 / V1.1.1 / s7810bp / EMMC
FW Size : 936 MiB
Scatter saved to : C:\Users\Desktop\MT6572__QMobile__QMobile_A300__QMobile_A300__4.2.2__ALPS.JB3.MP.V1.P65\

All done!


then i write tested file with sptool but it show brom error i formate it but no success .
i try with cm2 but same.

Code:

Scatter Load Ok , BaseBand : MT6572 , Project : s7810bp , Storage : EMMC
Files found : 12 , Set to Flash : 11
Ready to Flash!

Scatter Load Ok , BaseBand : MT6572 , Project : s7810bp , Storage : EMMC
Files found : 12 , Set to Flash : 11
Ready to Flash!

Start  at : [2/15/2016 / 8:07:08 PM]
Operation : Flash [ v1.40 ]

======= Flash
1. Power Off Phone , Remove battery , Insert back
2. Insert USB cable. In some cases require hold BootKey

Wait for phone...
Phone found! [ 8 ]
Sync...
Inital regs read done
Boot Info :
BB_CPU_ID : 6572
BB_CPU_HW : CA01
BB_CPU_SW : 8C00
BB_CPU_SB : 0000
BB_CPU_NM : [MediaTek] MT6572_S00
Processing BROM stage
BLVersion : 0x01
SecCfgVal : 0x00000000
BromVersion : 0xFF
BLVersion : 0x01
Preloader Status : Alive
Processing DA stage
DA Select done , sending
DA Ver : MTK_AllInOne_DA_v5.1540.01.01
NAND_ID : 00000000000000000000000000000000
eMMC_ID : 90014A4834473164048602A340DC4101
DA Stat : v4.2 on BBID : 0x88
DA Sent. Configure setting now ...
DA started successuflly
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0090 , OEM : 014A
[eMMC] : FLASH_INF : [HYNIX] , d1G4
[eMMC] : FLASH_CID : 90014A4834473164048602A340DC4101
[eMMC] : FLASH_EXT : 0x00200000 , 0x00200000 , 0x00200000
[eMMC] : FLASH_LEN : 0x00000000E7000000
[eMMC] : FLASH_UCP : 3696 MiB
INT RAM    : 0x00020000
EXT RAM    : 0x20000000
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

ScatCFG : BaseBand : MT6572 , Project : s7810bp , Storage : EMMC
Setting : Flash Pre-Erase (Safe) : Enabled
Setting : AFF verify :  Enabled
Setting : HW verify :  Enabled

BL : Check HW compatibility
BL : BBID supported by BootLoader!
BL : Check eMMC compatibility
BL : eMMC supported by BootLoader!

BL : BatteryLevel : 3828 mV
BL : BatteryLevel Ok

BL : Flash Pre-Erase
Total blocks to Erase : 2
Erase : 0x0000000000600000-0x0000000000100000
Erase : 0x0000000002300000-0x00000000E3E00000
Flash Pre-Erase Done, time used : 00:00:22

SecCfg Passed , 1799
BMT remark not need. Will skip
Sending Preloader ...
Use : preloader_s7810bp.bin
Preloader Init Failed! Looks like HW error or incompatible image
ErrCode :

Operation Failed
Elapsed: 00:00:41
Reconnect Power/Cable!

Finish at : [2/15/2016 / 8:07:53 PM]


Today i receive again a Q A300 with hang on logo and i flash it with sptool
and got done.
then i think i should take bin formate backup and write it on damage one.
but after backup second unit come hang on logo.
read file logs are here

Code:

Start  at : [2/16/2016 / 1:44:21 PM]
Operation : Check / Read Info [ v1.41 ]

1. Power Off Phone , Remove battery , Insert back
2. Insert USB cable. In some cases require hold BootKey

Wait for phone...
Phone found! [ 8 ]
Sync...
Inital Boot Ok!
BB_CPU_PID : 6572
BB_CPU_NME : [MediaTek] MT6572_S00
BB_CPU_EXT : 0xCA01 , 0x8C00 , 0x0000
Processing BROM stage
Settings for BROM configured!
SecCfgVal : 0x00000000
BromVer  : 0x00FF
BLVersion : 0x0001
PreLoader : Active [ Boot with PL ]
BootLdrSS : NORMAL with SPRELOADER
Processing DA stage
DA Select done, will use MTK_AllInOne_DA_v5.1552.01.01
Sending and initialize DA ...
Running DA ver.4.2 on BBID : 0x88
NAND Flash : NOT INSTALLED
eMMC Flash : 90014A4834473164048600A3319641D1
Initialize Memory ...
DRAM already initialized by Preloader
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0x90 , OEM : 014A
[eMMC] : FLASH_INF : [HYNIX] , d1G4
[eMMC] : FLASH_CID : 90014A4834473164048600A3319641D1
[eMMC] : FLASH_BRT : 0x00200000 , 0x00200000 , 0x00200000
[eMMC] : FLASH_LEN : 0x00000000E7000000
[eMMC] : FLASH_UCP : 3696 MiB [eMMC 4 GiB]
DEV RID    : A1630DDDC7B544BE28CC1FD6AF12B6B5
INT RAM    : 0x00020000
EXT RAM    : 0x20000000
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

[AP] : Initial info read Ok!

Brand    : QMobile
ProdName  : A300
ProdModel : QMobile A300
Device    : QMobile A300
AndroidVer: 4.2.2
MTKxCPU  : MT6572
MTKxPRJ  : ALPS.JB3.MP.V1.P65

EXTRA :
LCD [0] : ili9806c_fwvga_dsi_vdo_txdkj
LCD [1] : otm8018b_dsi_vdo
LCD Res : 854x480
TOUCH [0] : GT9XX
TOUCH [1] : FT5x36
CAM [0] : ov5645_mipi_yuv
CAM [1] : ov5644_mipi_yuv
CAM [2] : hi704_yuv
CAM [3] : sp0a19_yuv
MODEM : tinno72_s7810bp_pk_gprs_gemini
LOCALE : en_US es_ES zh_CN zh_TW ru_RU pt_BR fr_FR de_DE tr_TR it_IT in_ID ms_MY vi_VN ar_EG ur_PK fa_IR th_TH pt_PT nl_NL el_GR hu_HU tl_PH ro_RO cs_CZ iw_IL my_MM km_KH ko_KR hdpi

Done!
Elapsed: 00:00:07
Reconnect Power/Cable!

Finish at : [2/16/2016 / 1:44:28 PM]

Start  at : [2/16/2016 / 1:44:57 PM]
Operation : Read Flash [ v1.41 ]

1. Power Off Phone , Remove battery , Insert back
2. Insert USB cable. In some cases require hold BootKey

Wait for phone...
Phone found! [ 8 ]
Sync...
Inital Boot Ok!
BB_CPU_PID : 6572
BB_CPU_NME : [MediaTek] MT6572_S00
BB_CPU_EXT : 0xCA01 , 0x8C00 , 0x0000
Processing BROM stage
Settings for BROM configured!
SecCfgVal : 0x00000000
BromVer  : 0x00FF
BLVersion : 0x0001
PreLoader : Active [ Boot with PL ]
BootLdrSS : NORMAL with SPRELOADER
Processing DA stage
DA Select done, will use MTK_AllInOne_DA_v5.1552.01.01
Sending and initialize DA ...
Running DA ver.4.2 on BBID : 0x88
NAND Flash : NOT INSTALLED
eMMC Flash : 90014A4834473164048600A3319641D1
Initialize Memory ...
DRAM already initialized by Preloader
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0x90 , OEM : 014A
[eMMC] : FLASH_INF : [HYNIX] , d1G4
[eMMC] : FLASH_CID : 90014A4834473164048600A3319641D1
[eMMC] : FLASH_BRT : 0x00200000 , 0x00200000 , 0x00200000
[eMMC] : FLASH_LEN : 0x00000000E7000000
[eMMC] : FLASH_UCP : 3696 MiB [eMMC 4 GiB]
DEV RID    : A1630DDDC7B544BE28CC1FD6AF12B6B5
INT RAM    : 0x00020000
EXT RAM    : 0x20000000
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

Reading Flash Conent now ...

Read Ok , collect info
Brand    : QMobile
ProdName  : A300
ProdModel : QMobile A300
Device    : QMobile A300
AndroidVer: 4.2.2
MTKxCPU  : MT6572
MTKxPRJ  : ALPS.JB3.MP.V1.P65
Saved to : J:\MT6572__QMOBILE__QMobile_A300__A300__ALPS.JB3.MP.V1.P65__Android_4.2.2.ispff

Done!
Elapsed: 00:15:50
Reconnect Power/Cable!


now i cannot write any file on both of them fones.
I have tried to repair init preloader also.

now how to solve this problem.
anbody have solution?