Why I can`t use old version SmartZ ???


Why I can`t use old version SmartZ ???

SmartZ (not Pro) asks to update firmware, but:

Dongle SN:******** have the latest BB firmw version, nothing to update.

I buy dongle, and 2 or 3 week after I buy it, relesed new version SmartZ _PRO….. Now I must pay 65$ !?!?!?!?